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Abstract: Deficiency of insulin signaling in type 2 diabetes results from insulin resistance or defective 
insulin secretion and induce hyperglycemia. Diabetes is a global threat that continues to increase day by day 
at a very high rate in both developing and developed countries. Glucokinase activators (GKA) can be a novel 
target used for better management of type 2 diabetes. Recently novel GKA Dorzagliatin received market 
approval by Japan FDA for treatment of type 2 diabetes. The purpose of designing glucokinase activators 
was to develop novel therapeutic molecules with minimum side effects. A docking study was conducted 
using AutoDock Vina 1.5.6, and the structures were created using ChemBiodraw Ultra. The Swiss ADME 
algorithm was used for online log p prediction. Among all the molecules designed, AM35 had the highest 
binding affinity to GK receptors. For good absorption and elimination, Log P values range from 2-3.08, 
indicating good lipophilic properties. The new lead molecules were designed as glucokinase activators, 
which had a better pharmacokinetic profile and higher binding affinity. 
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1. Introduction 
Type 2 Diabetes Mellitus is marked by several 
distinctive features, which encompass heightened 
production of glucose in the liver, reduced 
sensitivity to insulin, compromised insulin release, 
and irregular fat processing [1]. During the initial 
phases of the condition, the pancreas' beta cells 
augment their insulin release as a response to the 
emerging insulin resistance, thereby maintaining 
relatively normal glucose tolerance [2, 3]. 
Nevertheless, in some individuals, the pancreatic 
islets eventually struggle to sustain this state of 
heightened insulin production and resistance as 
compensatory mechanisms wane. This progression 
results in impaired glucose tolerance, evident 
through elevated post-meal glucose levels [4, 5]. As 
the disease advances, overt diabetes becomes 
apparent, characterized by elevated fasting blood 
sugar due to decreased insulin secretion and 
heightened hepatic glucose synthesis [6, 7]. The 
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escalating global menace of diabetes continues to 
surge, with its prevalence steadily increasing across 
the world, spanning both developed and developing 
nations [8]. According to the Tenth Edition of the 
IDF Diabetes Atlas 2021, a staggering 537 million 
adults aged 20 to 79 are grappling with diabetes, 
with the year 2021 witnessing a distressing 6.7 
million diabetes-related fatalities [9, 10]. 
Projections indicate that the number of individuals 
affected by diabetes will soar to 643 million by 
2030 and an even higher 783 million by 2045 [11, 
12]. A significant majority, about 81%, of adults 
afflicted by diabetes are situated in low and middle-
income economies. Over the last 15 years, diabetes 
has accounted for at least USD 966 billion (a 316% 
increase) in healthcare expenditures [13, 14]. Of 
utmost concern is the fact that nearly half, 
specifically 46.5%, of adults with diabetes remain 
undiagnosed. Glucokinase (GK) is an enzyme 
located in the cytoplasm that facilitates the 
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conversion of glucose into glucose-6-phosphate 
through phosphorylation [15]. The primary sites of 
GK expression are the pancreatic β-cells and 
hepatocytes within the liver. In the β-cells of the 
pancreas, GK serves as a molecular detector, 
triggering insulin release in response to glucose 
stimulation [16, 17]. The extent of glucose 
phosphorylation in pancreatic β-cells is directly 
proportional to the glucose concentration, 
regulating the rate of insulin secretion [18]. By 
regulating both glycolysis and ATP production, 
glucokinase preserves optimal ATP/ADP ratios. 
When the membrane potential reaches a specific 
threshold, GK prompts the opening of L-type 
calcium channels. This Ca2+-dependent process 
leads to insulin release. Activation of GK 
contributes to the restoration of insulin secretion 
and calcium response in pancreatic islets. In 
hepatocytes, GK plays a pivotal role in glucose 
metabolism [19]. Its activity is modulated by 
glucokinase regulatory protein (GKRP), an inherent 
inhibitor. At low glucose levels, GK is inactive and 
bound to GKRP in the nucleus. GK activators 
(GKAs) bind to an allosteric site on the enzyme. 
They can activate GK directly and disrupt the 
GK/GKRP complex, causing its dissociation. As 
blood glucose levels rise, GK translocates to the 
cytoplasm [20]. GKAs not only enhance insulin 
secretion but also foster glycolysis and glycogen 
synthesis, thereby improving glucose tolerance. In 
2003, Hoffmann-La Roche AG introduced the 

GKA compound RO-281675, which amplified 
GK's maximum metabolic rate (Vmax) by 1.5-fold 
at 3 µM concentration. The glucose concentration 
(S0.5) required for half of Vmax decreased from 86 
mM to 20 mmol/L [21]. Despite its potential as a 
diabetes management tool, this compound never 
underwent clinical trials due to cardiovascular 
risks. However, its development inspired other 
pharmaceutical companies to create efficient and 
safe GKAs [22]. In recent years, a range of 
molecules with heterocyclic structures—containing 
nitrogen, sulfur, oxygen, and amide linkages—have 
emerged as potential GK activators in Figure 1. 
These molecules interact with GK's allosteric site, 
prompting researchers to explore alternative core 
nuclei for developing novel GKAs with superior 
potency, efficacy, enhanced physicochemical 
properties, and reduced toxicity [23]. Research has 
been driven to find potent glucokinase activators 
with fewer adverse effects due to current drugs' 
ineffectiveness and side effects. Computer 
simulations, software is used to assemble, prepare, 
process, and evaluate data as well as construct and 
evaluate models. In addition to being economical, 
computer-aided designs make experiments and 
predictions easier to assess [24]. Therefore, our 
current research work focused on building a virtual 
library of heterocyclic derivatives, investigating 
their binding affinity to GK active pockets, and 
analyzed their pharmacokinetics and toxicity 
profiles [25]. 
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Figure 1. Glucokinase activators available in Market. 
 

Montano et al. designed benzimidazole derivatives 
as GKAs and study revealed compound 1, in Figure 
2, showed good potential as a blood glucose control 
drug since presenting an increase of GK (2.86 and 
3.74-fold at 100 and 200 μg mL−1) (26). Sharma & 
co-workers synthesized pyridine amide derivatives 

and analysed their GK activation potential. Based 
on their docking scores compound 2, in Figure 2, 
demonstrate highest binding affinity of -9.1 
kcal/mol (27). Hamid et al. designed benzene 
sulphonamide derivatives and in vitro enzymatic 
activity assay results compound 3, in Figure 2, 



Turkish Comp Theo Chem (TC&TC), 8(3), (2024), 74-98 

Anuradha Mehra, Amit Mittal, Pankaj Wadhwa, Aryan Mehra 
 

76 
 

exhibits 1.37 fold GK activation (28). Kazi & 
colleagues performed in-silico designing of 
benzamide derivatives as GKAs. Docking studies 
revealed 4 (Figure 2) binding interactions with Arg 
63 residue for the best-fit conformations in the 
binding site of the GK enzyme and show 1.5 fold 
GK activation (29). Arora et al. designed N-
benzothiazol-2-yl is attached to the benzamide 
nucleus to form novel derivatives as GKA. 
Compound 5 (Figure 2) exhibit effective GK 
activation by 1.97 folds (30). Khadse & co-workers 
synthesized sulfonamido-benzamide hybrids and 
compound 6 show EC50 as 495 nM. In-vivo OGTT 
assay, compound 6 (Figure 2) disclosed an extreme 
decrease in blood glucose level as 135 mg/dL (31). 
In another study conducted by Khadse & group 
include design, synthesis, and evaluation of 
quinazolin-4-one derivatives as GKAs. Compound 
7 (Figure 2) with EC50 of 516 nM demonstrate the 
highest in vitro GK activation (32). Grewal et al. 

synthesized 3,5‑disubstituted benzamide 
derivatives as GKA. Compound 8 (Figure 2) exhibit 
promising GK activity as 2.11 μM and 250 mg/dL 
glucose reduction at 120 min interval in OGTT 
assay (33). Charaya & colleagues aimed to enhance 
the activity of GK in the benzamide nucleus, 
thiazol-2yl is substituted at amido nitrogen and 
aromatic moieties are substituted at the sulfonamide 
group. In vivo OGTT assay results demonstrate 
compound 9 (Figure 2) reduces blood glucose 
equipotent to that of the standard drug (metformin 
blood glucose level reduction is 125 mg/dL) at 120 
min time interval (34). Kohn et al. designed and 
evaluate the GK activity of the prepared 5-alkyl-2-
urea-substituted pyridines derivatives. A dose-
proportional diminution in blood glucose levels was 
observed when compound 10 (Figure 2) was 
administered at doses of 3, 10, 30, and 100 mg/kg 
during OGTT assay, displaying a 40% reduction in 
AUC at 100 mg/kg (35). 
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Figure 2. Glucokinase activators (compounds 1-10) explored in the literature review 

 
Glucokinase, a member of the hexokinase enzyme 
family, undergoes activation upon stimulation. 
Activating the GK enzyme is triggered by GKA 
interacting with its allosteric site (36). Functioning 
as a discerning "glucose sensor," GK orchestrates 
insulin secretion in the pancreatic β-cells, 
responding dynamically to glucose levels (37). The 
liver's glycogen synthesis and storage are promoted 
by GK, a key glucose "gatekeeper." GK activation 
by small molecules has been proposed as an 
innovative method to enhance glycemic control in 
patients with diabetes (38, 39). GK functions as a 
molecular sentinel within pancreatic beta cells for 
insulin release in response to glucose stimulation 
(40). A novel heterocyclic derivative of GKA 
propels the activity of GK by firmly binding to it. 
GK catalyzes glucose phosphorylation within 

pancreatic acinar cells, a process directly related to 
glucose concentration. So, regulation of insulin 
secretion is determined by glucose phosphorylation 
rate (41). ADP/ATP ratios are maintained by 
glucokinase's modulation of glycolysis and 
oxidative ATP production. Insulin is released 
calcium-dependently when GK reaches its 
membrane potential threshold. As a result of this 
process, GK activation restores insulin secretion in 
pancreatic islets (Figure 3) and calcium response to 
glucose (42). This intricate pathway enables novel 
heterocyclic derivatives to produce hypoglycemic 
agents capable of reducing blood glucose levels, an 
important component of the management of type 2 
diabetes (43).  
Among antidiabetic drugs, metformin is associated 
with drug resistance when used in long-term use. 
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Furthermore, conventional oral hypoglycaemic 
drugs (e.g. pyrazolidines, sulfonylureas and 
acarbose) may cause severe side effects and have 
sundry drawbacks (e.g. poor efficacy). Thus, it is 
imperative to develop new anti-diabetic drugs. By 
increasing glucose uptake and lowering blood 
glucose levels, glucokinase activators exhibit 
promising treatment of type 2 diabetes. In spite of 
this, it is important to design GKAs that are 
effective as well as minimally side effects. The liver 

and pancreas should be the only organs targeted by 
GKAs without adversely affecting other organs 
such as the brain or the heart. It is expected that 
GKAs will not adversely affect other physiological 
processes, such as insulin sensitivity and lipid 
metabolism. Studies examining chronic GKA use 
need to be conducted for an accurate assessment of 
potential risks. Resistance to oral antidiabetic drugs 
should be overcome by GKAs. 

 
Figure 3. Mechanism of action of novel heterocyclic derivatives as GKAs 

 
Development of strategies for preventing or 
reversing drug resistance requires an understanding 
of the molecular mechanisms underlying resistance. 
It may be possible to improve glucose control in 
T2DM patients by combining GKAs with other 
antidiabetic drugs, such as metformin. In light of 
this, combination therapies targeting different 
aspects of glucose metabolism could provide a 
promising approach for T2DM. The current 
landscape of GKA drugs has significant research 
gaps and challenges, particularly regarding their 
safety and efficacy over the long term. A 

comprehensive understanding of their extended 
safety profiles remains elusive, despite their 
potential to improve glycemic control through 
glucokinase activation. Several challenges stand in 
the way of more effective development of GKAs, 
including the variability of each patient's response, 
the possibility of off-target effects, and the limited 
knowledge available about the intricate 
mechanisms influenced by these proteins. It is also 
difficult to implement these interventions in 
practice because of issues such as patient 
adherence, variability in pharmacokinetics, and the 
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need for effective patient stratification. 
Development of novel heterocyclic derivatives has 
the potential to advance GKA therapies in the 
future. In addition to providing greater specificity, 
efficacy, and safety, these derivatives could help 
address today's challenges. Through this research, 
new insights could be gained into glucokinase 
activation, mechanistic insights could be 
uncovered, and new therapeutic strategies could be 
developed to effectively manage diabetes. In order 
to advance the field and ultimately improve 
treatment outcomes for diabetic patients, 
comprehensive investigations into their 
pharmacological properties, safety profiles, and 
potential synergies are imperative. 
 
2. Computational Method 

2.1. Research tools 
Vina 1.5.6 AutoDock (44) tool is used to analyze 
GK activation in terms of binding affinity 
(Kcal/mol) and compare them with the molecules' 
best-docked conformation binding affinity score. 
2D and 3D structure of the compounds was created 
using ChemBiodraw ultra and ChemBiodraw 3D 
software. By employing the MM2 approach, each 
molecule's energy was minimised so that its 
performance could be maximized. Also, AutoDock 
Vina transformed the derivatives' format into a 
more decipherable format. Glucokinase activation 
was identified by downloading proteins with the 
PDB ID 1V4S from the protein data bank (45). 
Examining the results of compound interactions 
involved utilizing Biovia Discovery Studio 
Visualizer (46) and Pymol software (47) to 
ascertain their poses. 
 

2.2. Default Directory Setup 
In Autodock, the default directory setup was done 
using following steps: Go to File > Preferences > 
Set, input C:\workspace under Startup directory, 
click Set, and then Make default. This process 
establishes the default directory as the default 
storage location for all docking files. 
 

2.3. Protein Selection and Preparation 
The glucokinase activation activity was determined 
using the pdb code 1V4S from the RCSB Protein 
Data Bank (https://www.rcsb.org/). The protein 
was then loaded into the AutoDock Vina software 
program for extraction of the protein and ligand 

individually. The main goal of this software is to 
find potential hit compounds with high binding 
affinity. 
The desktop shortcut provided access to the 
AutoDock tool. Open the macromolecule file 
(1V4S.pdb) in the workspace folder by selecting 
File > Read Molecule. The water can be removed 
by selecting Edit > Delete Water. The 
macromolecule can be hydrogenated by clicking 
Edit > Hydrogens > Add > All Hydrogens > OK. 
Non-polar hydrogen can be merged with other non-
polar hydrogen by selecting Edit > Hydrogen > 
Merge Non-Polar. Using the Edit > Charges menu, 
click Compute Gasteiger and add all the Gasteiger 
charges that were calculated. Modifications can be 
saved by selecting File > Save > Write PDB > OK. 
Workspace folder is updated with the updated pdb 
file when this action is performed. Select the 
macromolecule under Grid > Macromolecules > 
Choose > OK. It should be saved as "protein.pdbqt" 
in the same folder where the pdb files are kept. 
 

2.4. Validation of Protein for Docking 
An analysis of the ligand structure has been 
conducted using a protein structure (.pdb) file, 
1V4S, which is docked repeatedly with the binding 
site. A RMSD (Root Mean Square Deviation) 
analysis was conducted in order to determine 
reproducibility and validity of the method based on 
redocked binding sites with ligand atoms and 
crystallographic conformations. 
 

2.5. Ligand Preparation 
An extensive library of heterocyclic derivatives was 
screened in order to determine which one had the 
best binding affinity. ChemBioDraw 2D was then 
used to create the 2D structures. Additionally, 
three-dimensional structures of the ligands were 
created with ChemBioDraw 3D. Autodock Vina 
software1.5.6 program to analyze the ligands, the 
ligands were stored as .pbd files. 
Open the ligand file "AM1.pdb" within AutoDock 
by selecting Ligand > Input > Open. An AutoDock 
analyzes the structure of a ligand, incorporating 
charges and identifying rotational bonds 
autonomously. In this instance, a noteworthy 
discovery unfolded, revealing number of aromatic 
carbons and the detection of number of rotatable 
bonds. To detect the root, proceed with select 
Ligand > Torsion Tree > Detect root. Within the 

https://www.rcsb.org/
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AutoDock visualization window, a green circle will 
indicate the presence of the root. The ligand file can 
be saved by choosing Ligand > Output > Save as 
pdbqt. Each subsequent ligand from AM2 to AM60 
should be meticulously replicated in this manner. 
 

2.6. Configuring Grid Spacing 
Identifying potential binding sites for a 
macromolecule based on grid box boundaries. 
Choosing 1V4S.pdb by Navigating to Grid > 
Macromolecule > Choose. In the same workspace, 
save the updated Macromolecule as a pdbqt file. 
Choose ligand > Select MRK > Click ligand in Grid 
> Set map types. The Grid Box can be accessed by 
selecting Grid > Grid Box. The current setup will 
be saved after selecting File > Close. The next step 
is to navigate to Grid > Output > Save. Save the file 
in the workspace folder with the name "conf". 
 

2.7. Molecular Docking Study 
To find the hit GK activators, a molecular 
modelling tool was used to examine the designed 
library of molecules. Based on the binding of GK 
active site, the selected 1V4S protein was 
engendered. By removing its ligand, the protein 
was validated, then polar hydrogen bonds were 
added, root was identified, and the file was 
transformed into the (.pdbqt) format. Further, to 
produce the 1V4S protein, water molecules were 
eliminated, any missing atoms were replaced, only 
polar hydrogen was added, and lastly, Kollman 
charges were included. By keeping ligand as a 
center, the grid box was generated. Using the grid 
output file, the following parameters (x, y and z 
dimensions) were added to the "conf.txt" 
configuration file. 

Center_x = 40.144 
Center_y = 14.796 
Center_z = 62.039 
Size_x = 30 
Size_y = 44 
Size_z = 24 

A command prompt was opened and the command 
"program files/the Scripps research 
institute/vina/vina.exe - config conf.txt - log 
log.txt" was typed for performing molecular 
docking with Vina using the AutoDock Tool. 
 
 
 

2.8. Docking Analysis 
In the workspace generated following Autodock 
completion, select Analyze > Dockings > Open, 
and locate the dock.outpout file there. Select 
AM1.pdbqt under Analyze > Macromolecule > 
Choose. Additionally, select Analyze > 
Conformations > Play, with energy order. 
Following that, each conformation should be 
analyzed and inspected separately. Each compound 
should be assessed meticulously by repeating this 
process. Binding affinity (Kcal/mol) or docking 
scores were generated as output files. Based on 
Discovery Studio Visualizer software, in-silico 
bond length and hydrogen bond interaction were 
investigated for the best-designed molecules that fit 
the GK active pocket is summarised in table 1 
below. 
 
2.9. ADME Analysis to find the Lead Molecules 
Screening and estimation of the 8 hit compounds 
were performed using SwissADME 
(http://www.swissadme.ch). Chemical structures 
will be imported or drew using SwissADME's 
molecular sketcher built on Chemaxon's Marv (48), 
which allows import or drawing of 2D chemical 
structures. Molecular SMILES can be edited, typed, 
or pasted since the Smile ID of each molecule is 
also accepted. In BIOLED-eggs, various 
physiochemical characteristics are observed, such 
as p-glycoprotein interactions, Lipinski rule of 5 
(49) or drug penetration in the blood-brain barrier 
and gastrointestinal absorption. This computational 
method was used to select lead molecules with lead-
like characteristics for focused GK activation. 
 

2.10. Toxicity Prediction 
pkCSM software (50) was used for the 
comprehensive toxicity assessment of the potent 
compounds AM35 and AM2. A number of 
parameters, including cardiotoxicity, 
hepatotoxicity, and others, were taken into account 
when predicting the results. 
 
3. Results and discussion 

3.1. Rationale Drug Design 
A strategic approach to designing novel 
heterocyclic derivatives AM1-AM20 for type 2 
diabetes treatment relies on integrating multiple 
pharmacophores that are clinically proven to be 
anti-diabetic. Inspired by CN102558167 (GKA 

http://www.swissadme.ch/
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filed by Institute of Materia Medica), which has 
demonstrated compound A (Figure 4) with 2.9 folds 
of GK activation at 10 µM, efficacious in 

improving insulin sensitivity, which incorporates 
thiazolidinedione moiety as key elements, this 
scaffold is incorporated in the design (51). 
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Figure 4. Rationale drug design of novel heterocyclic derivatives. 

 

Further, as compound B, C and D (Figure 4) exhibit 
potent GK activation with EC50 value of 0.014 µM 
(in-vitro assay), 23.3% and 75.2% blood glucose 
lowering in OGTT assay respectively as disclosed 
in patents WO2010150280 and WO2011013141, 
the inclusion of an oxadiazole core enriches 
molecular diversity, aligning with the therapeutic 
benefits associated with such structures (52, 53). 
Compounds A-F (Figure 4), characterized by a 
common pharmacophoric feature involving amide 
or sulfonamide groups, have demonstrated robust 
activation of glucokinase, which is vital for 
promoting GK activity. As the design incorporates 

these insights, it is aimed at creating a synergistic 
pharmacological profile, leveraging 
thiazolidinedione, oxadiazole, and amide or 
sulfonamide functionalities in combination. As a 
result of systematic exploration of SAR based on 
the incorporation of these pharmacophores, the aim 
is to discover novel heterocyclic derivatives (AM1-
AM20) with improved glucokinase activation, 
which may help facilitate the development of 
innovative and more efficacious treatments for type 
2 diabetes. In light of the patent applications, 
US8957070B2 and WO2014099578A1 feature 
compounds E and F (Figure 4), considered as 
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robust glucokinase activators with EC50 value of 1.9 
nM and 0.019 µM, both of which belong to the 
indole class (54, 55). The strategic departure in the 
design of heterocyclic derivatives AM21-AM40 
include replacement of thiazolidinedione ring with 
an indole moiety that is intended to introduce 
structural diversity and enhance anti-diabetic 
activity. In this modification, a new structural 
element is introduced, which may allow modulation 
of the molecular interaction, thus optimizing the 
drug's effectiveness. Grewal et al. designed natural 
coumarin derivatives, and through in-silico 
assessment, compound G and H (depicted in Figure 
4) demonstrated significant potential as an effective 
treatment for type 2 diabetes by activating 
glucokinase with binding affinity of -8.4 and -8.1 
kcal/mol (56). The effect of substituting the indole 
ring with the coumarin (chromene) nucleus on GK 
activation was explored using a comprehensive 
substitution strategy following the 
conceptualization of the proposed heterocyclic 
derivatives (AM41-AM60). 
 

3.2. Molecular Docking 
A screening was conducted using the estimated free 
binding energies expressed in Kcal/mol for the 
actively targeted GK, a glucose-sensing, which 
stimulates insulin secretion in pancreatic cells, and 
also a glucose "gatekeeper" in hepatocytes, which 
promotes glucose uptake as well as glycogen 

synthesis and storage. Compounds docked to GK 
proved to have higher binding affinity than the 
primary ligands. In the GK active pocket, MRK had 
a free binding energy of -7.2 Kcal/mol. An 
estimated binding energies of Dorzagliatin 
(approved by Japan FDA as GKA), Canagliflozin 
and Dapagliflozin (marketed antidiabetic agents) 
was found to be -7.2, -9.4 and -7.3 respectively. A 
strong binding affinity was observed for the 
molecules AM35, AM2, AM12, AM17, AM58, 
AM5, AM14, AM16, AM19, AM52 and AM57 (-
11.6, -11.3, -11.1, -11.1, -11.0, -11.0, -10.8, -10.8, -
10.8, -10.8, -10.8 kcal/mol respectively) when 
compared with MRK (-7.2 kcal/mol), Dorzagliatin 
(-7.2 kcal/mol), Canagliflozin (-9.4 kcal/mol), 
Dapagliflozin (-7.3 kcal/mol). Tables 2 and 3 list 
the compounds docked in the binding pockets of the 
target with scores and amino acids interactions that 
reveal binding affinities. Binding affinity of the 
docked molecules is between -11.6 and -10.8 
Kcal/mol. 
As shown in Figure 5, the MRK had hydrogen bond 
interactions with TYR215 and THR65. The Pi-
Alkyl interactions were found with ILE211, 
PRO66, VAL455, VAL62, ALA456 and ILE159. 
The Pi-sulfur interactions with MET235 and 
ARg63. The Van der Waals interaction with 
LEU451, SER64, GLU221, TYR214, MET210 and 
TYR61. 
 

 

Table 1. Structures and binding affinity of derivatives derived from rational drug design. 

Sr. No Compound Structure Binding affinity 
(Kcal/mol) 

  1. AM1 
NH

S

O

O
O

N N
HNC

O

Cl  

-10.0 

  2. AM2 
NH

S

O

O
O

N N
HNC

O
Cl

 

-11.3 

   3. AM3 
NH

S

O

O
O

N N
HNC

O
Cl

Cl  

-7.7 

  4. AM4 
NH

S

O

O
O

N N
HNC

O

OH  

-9.1 

  5. AM5 
NH

S

O

O
O

N N
HNC

O
HO

 

-11.0 
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   6. AM6 
NH

S

O

O
O

N N
HNC

O

 

-9.0 

   7. AM7 
NH

S

O

O
O

N N
HNC

O

 

-9.9 

  8. AM8 
NH

S

O

O
O

N N
HNC

O

 

-9.7 

   9. AM9 
NH

S

O

O
O

N N
HNC

O

OCH3  

-8.2 

 10. AM10 
NH

S

O

O
O

N N
HNC

O

NH2  

-9.1 

 11. AM11 
NH

S

O

O
O

N N
HNC

O
H2N

 

-9.5 

12. AM12 
NH

S

O

O
O

N N
HNC

O
O2N

 

-11.1 

13. AM13 
NH

S

O

O
O

N N
HNC

O
Br

 

-9.7 

14. AM14 
NH

S

O

O
O

N N
HNS

O

O

N

 

-10.8 

15. AM15 
NH

S

O

O
O

N N
HNS

O

O  

-12.4 

16. AM16 
NH

S

O

O
O

N N
HNS

O

O
O

 

-10.8 

17. AM17 
NH

S

O

O
O

N N
HNS

O

O
F

 

-11.1 

18. AM18 
NH

S

O

O
O

N N
HNS

O

O
F  

-10.7 

     19. AM19 
NH

S

O

O
O

N N
HNS

O

O  

-10.8 

     20. AM20 
NH

S

O

O
O

N N
HNS

O

O  

-9.8 

     21. AM21 

N N

O
NH C

O
HN Cl

 

-8.8 
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     22. AM22 

N N

O
NH C

O
HN

Cl
 

-10.1 

     23. AM23 

N N
O

NHC
OHN

Cl

Cl

 

-10.4 

     24. AM24 

N N
O

NHC
HN HO

O  

-10.6 

     25. AM25 

N N
O

NHC
OHN

OH
 

-9.7 

     26. AM26 

N N
O

NH C
OHN

 

-10.5 

     27. AM27 

N N
O

NHC
OHN

 

-9.9 

     28. AM28 

N N
O

NHC
OHN

 

-10.4 

     29. AM29 

N N
O

NHC
OHN

OCH3
 

-9.9 

     30. AM30 

N N
O

NH C
HN H2N

O  

-9.7 

     31. AM31 

N N
O

NHC
OHN

NH2
 

-9.9 

     32. AM32 

N N
O

NHC
OHN

NO2
 

-7.6 
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     33. AM33 

N N
O

NHC
OHN

Br
 

-10.3 

     34. AM34 

N N
O

NH S
O NHN

O  

-9.7 

     35. AM35 

N N
O

NH S
OHN

O  

-11.6 

     36. AM36 

N N
O

NHS
OHN

O
OCH3

 

-8.8 

     37. AM37 

N N
O

NH S
OHN

O
F

 

-10.2 

     38. AM38 

N N
O

NH S
OHN

O

F

 

-9.8 

     39. AM 39 

N N
O

NH S
OHN

O  

-10.1 

     40. AM40 

N N
O

NH S
OHN

O  

-10.7 

     41. AM41 O O

N N

O
NH C

O
Cl

 

-10.2 

     42. AM42 O O

N N

O
NH C

O
Cl

 

-7.8 

     43. AM43 O O

N N

O
NH C

O
Cl

Cl

 

-10.4 
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     44.  AM44 O O

N N

O NH C
O
HO

 

-9.7 

     45. AM45 O O

N N

O
NH C

O
OH

 

-9.6 

     46. AM46 O O

N N

O NH C
O

 

-8.6 

     47. AM47 O O

N N

O NH C
O

 

-10.1 

     48. AM48 O O

N N

O NH C
O

 

-10.6 

     49. AM49 O O

N N

O
NH C

O
OCH3

 

-9.6 

    50. AM50 O O

N N

O NH C
O
H2N

 

-9.7 

    51. AM51 O O

N N

O
NH C

O
NH2

 

-9.9 

    52. AM52 O O

N N

O
NH C

O
NO2

 

-10.8 

    53. AM53 O O

N N

O NH C
O

Br
 

-9.8 

54. AM54 O O

N N

O NH S
O

O

N

 

-9.8 

55. AM55 O O

N N

O NH S
O

O  

-9.8 

56. AM56 O O

N N

O
NH S

O

O
OCH3

 

-10.6 

57. AM57 O O

N N
O NH S

O

O
F

 

-10.8 

58. AM58 O O

N N

O NH S
O

O

F

 

-11.0 
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59. AM59 O O

N N
O NH S

O

O  

-10.6 

60. AM60 O O

N N

O NH S
O

O  

-10.4 

61. Co-cryst Ligand 
(MRK) 

O
N
H

S
N

S
N

N

F NH2  

-7.2 

62. Canagliflozin 
S FOHO

HO
OH

OH
 

-9.4 

63. Dapagliflozin 

Cl O
OHO

HO
OH

OH

 

-7.3 

64. Dorzagliatin  

O

H
N N

N
OHHO

N

O
O

Cl

 

-7.2 

 

As shown in Figure 6, the AM35 had hydrogen 
bond interactions with ARG63, CYS220 and 
THR65. The Pi-Alkyl interactions were found with 
ILE159, ALA456, VAL62, ILE221, MET210. The 
Pi-Pi stacked interactions were found with 
TYR214. The Pi-sulfur interactions with MET235. 
The Van der Waals interaction with TYR61, 
SER64, ARG250, GLU221.  

As shown in Figure 7, the AM2 had Pi-Alkyl 
interactions with MET210, MET235, ILE211, 
VAL62, VAL452, LYS459, ILE159. The Pi-Pi 
stacked interactions were found with TYR214. Pi-
Sigma interactions were found with ALA456 and 
VAL455. The Van der Waals interaction with 
GLU221, CYS220, THR65, TYR215, GLN98, 
ARG63 TYR61.  

 

 
Figure 5. The MRK showing interactions in the GK. 

 
As shown in Figure 8, the AM12 had hydrogen 
bond interactions with TYR215. The Pi-Alkyl 
interactions were found with ILE159, ALA456, 
VAL62, ILE221, MET210. The Pi-Pi stacked 

interactions were found with TYR214. The Van der 
Waals interaction with TYR61, SER64, ARG250, 
GLU221.  
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As shown in Figure 9, the AM17 had hydrogen 
bond interactions with THR65. The Pi-Alkyl 
interactions were found with ILE159, PRO66, 
VAL452, VAL62, ILE211, MET235. The Pi-
Sigma interactions were found with ALA456, 
VAL455. The Van der Waals interaction with 
LYS459, TYR215, CYS220, TYR214, GLU221, 
ARG250, MET210, SER64, ARG63. 
As shown in Figure 10, the AM58 had hydrogen 
bond interactions with THR65. The Pi-Alkyl 
interactions were found with MET235, ILE211, 
VAL62, ALA456, PRO66. The Pi-Sigma 

interactions were found with VAL455. The Van der 
Waals interaction with ARG250, GLU221, 
HIS218, ILE159, ARG63, MET210.  
As shown in Figure 11, the AM5 had Pi-Alkyl 
interactions with ILE211, VAL452, PRO66, 
VAL62, ALA456, ILE159, LYS459. The Pi-Sigma 
interactions were found with VAL455. Pi-Sulfur 
interactions was found with MET235. The Pi-Pi T-
shaped interaction was found with TYR214. The 
Van der Waals interaction with ARG250, GLU221, 
HIS218, ILE159, ARG63, MET210. 

 

 
Figure 6. The AM35 showing interactions with GK. 

 
Figure 7. The AM2 showing interactions with GK. 
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Figure 8. The AM12 showing interactions with GK. 

As shown in Figure 12, the AM14 had Pi-Alkyl 
interactions with VAL452, VAL455, VAL62, 
ILE159, ARG63, LYS459. The Pi-Sigma 
interactions were found with VAL455. Pi-Sulfur 
interactions was found with MET235. The Pi-Pi T-
shaped interaction was found with TYR214. The 
Van der Waals interaction with SER64, TYR215, 
ILE211, GLN98, TYR61, ASP158, THR65, 
PRO66, ALA456, ASP158. 
As shown in Figure 13, the AM16 had Pi-Alkyl 
interactions with LYS459, ILE159, VAL62, 
VAL455, VAL452, ILE211, MET235. The Pi-Pi 
stacked interaction was found with TYR214. The 

Van der Waals interaction with ASP158, TYR61, 
TYR215, THR65, GLU221, MET210, CYS220, 
ALA456, PRO66.  
As shown in Figure 16, the AM57 had hydrogen 
bond interactions with THR65. Pi-Alkyl 
interactions with PRO66, ALA456, VAL62, 
MET235. The Pi-Pi T shaped interactions were 
found with TYR214. Pi-cation interaction was 
found with ARG250. Pi-Sigma interaction was 
found with VAL455. The Van der Waals 
interaction with CYS220, TYR215, LEU451, 
ILE159, TYR61, SER64, MET210, ARG63. 

 
Figure 9. The AM17 showing interactions with GK 
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Figure 10. The AM58 showing interactions with GK 

 
Figure 11. The AM5 showing interactions with GK. 

 
Figure 12. The AM14 showing interactions with GK. 
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Figure 13. The AM16 showing interactions with GK. 

 
Figure 14. The AM19 showing interactions with GK. 

 
Figure 15. The AM52 showing interactions with GK. 
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Figure 16. The AM57 showing interactions with GK. 

Table 2: The binding affinity of hit compounds with their hydrogen bond interactions and other interactions with 
neighbouring protein residues in GK active pockets. 
Sr. No. Compound Binding 

affinity 
H-bond Pi-Alkyl Pi-sigma Pi-pi T- 

shaped 
1 AM35 -11.6 ARG63 CYS220 

THR65 
ILE159 ALA456 VAL62 
ILE221 MET210 

- TYR214 

2 AM2 -11.3 TYR215 MET210 MET235 ILE211 
VAL62 VAL452 LYS459 
ILE159 

ALA456 
VAL455 

TYR214 

3 AM12 -11.1 THR65 ILE159 ALA456 VAL62 
ILE221 MET210 

- - 

4 AM17 -11.1 THR65 ILE159 PRO66 VAL452 
VAL62 ILE211 MET235 

ALA456 
VAL455 

- 

5 AM58 -11.0 - MET235 ILE211 VAL62 
ALA456 PRO66 

VAL455 TYR214 

6 AM5 -11.0 - ILE211 VAL452 PRO66 
VAL62 ALA456 ILE159 
LYS459 

VAL455 TYR214 

7 AM14 -10.8 - VAL452 VAL455 VAL62 
ILE159 ARG63 LYS459 

VAL455 TYR214 

8 AM16 -10.8 - LYS459 ILE159 VAL62 
VAL455 VAL452 ILE211 
MET235 

- TYR214 

9 AM19 -10.8 THR65 ILE159 PRO66 VAL62 
VAL452 ILE211 MET235 

VAL455 
ALA456 

- 
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10 AM52 -10.8 ARG63 TYR215 
THR65 

PRO66 VAL455 VAL452 
ILE211 MET235 

- TYR214 

11 AM57 -10.8 THR65 PRO66 ALA456 VAL62 
MET235 

VAL455 TYR214 

12 MRK -7.2 TYR215 THR65 ILE211 PRO66 VAL455 
VAL62 
ALA456 ILE159 

- - 

 

 
                               A                                                                                                      B 

Figure 17. A. Overlapping of co-crystallized ligand and designed ligands to ensure validation.  
B. Validation Pose of co-crystallized ligand and designed heterocyclic derivatives. 
 

3.3. Molecular docking validation studies 
Molecular docking protocols and methods (57) 
were validated by redocking the cocrystallized 
ligands at their crystal positions (Figure 17B) 
without introducing any conformers or changing 
their states. It was found that MRK's, RMSD values 
= 1 when the crystallographic conformation was 
superimposed on the cocrystallized ligand's docked 
position. Docking of molecular molecules is often 
done using RMSD (root mean square deviation) 
values to test the quality of the reproduction binding 
pose. In general, the bound structure prediction is 
considered to be accurate when the pose's RMSD is 
less than 1, while other values between 1 to 3, are 
deemed acceptable (58). Reproducibility had 
ensured for virtual screening results. In order to 
confirm consistency of the results, the virtual 
screening was reran using the same dataset and 
parameters. Additionally, among all poses, the one 
depicting ligand overlap with the cocrystallized 
ligand (Figure 17A) was chosen for evaluation 
regarding docking scores and interactions with 
amino acids. 

 
 

3.4. ADME Analysis 

A candidate molecule's physio-chemical properties 
had a significant impact on its fate. In table 3 the 
physiochemical characteristics of 11 hit 
compounds, such as their molecular weight, Log P 
value and hydrogen bond acceptors and donors. 
Bioavailability scores for the hit compounds were 
similar to the standard MRK, with a bioavailability 
score of 0.55. Using Lipinski's rule of five to 
evaluate the similarity of compounds to drugs, 
every hit compound passed the test. Among the 
eight compounds tested, compounds AM35 and 
AM2 showed the highest binding affinity, which 
was -11.6 and -11.3 Kcal/mol, respectively. AM35 
and AM2 contains five hydrogen bond acceptors 
and 6 hydrogen bond acceptors respectively. Both 
these compounds showed 2 hydrogen bond donors. 
AM35 showed high GI absorption and were not 
able to cross the blood-brain barrier with Log P 
values of 2.41. 
 

3.5. TOXICITY 
Based on the provided data, the properties of 
compounds AM35, AM2, and the standard 
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compound MRK were analyzed, considering their 
AMES toxicity, MTD (human) log mg/kg/day, 
ORAT (LD50) mol/kg, hepatotoxicity, skin 
sensitization, T.Pyriformis toxicity log µg/mL, and 
minnow toxicity (mM). In terms of AMES toxicity, 
both AM2 and MRK are classified as non-AMES 
toxic, while AM35 falls into the category of AMES 

toxic. Concerning the MTD (human) log 
mg/kg/day, AM2 is associated with a positive value 
of 0.163, indicating a potential safe dosage, 
whereas AM35 exhibits a negative value (0.798), 
suggesting caution in determining the maximum 
tolerated dose. 

 
Table 3. The drug-likeness property of hit heterocyclic derivatives using SwissADME tool. 
Sr.no Compound MW H-bond 

acceptor 
H-bond 
donor 

LOG 
P 

GI 
absorption 

BBB 
permeant 

Bioavailability 

1 AM35 390.42 5 2 2.41 High No 0.55 
2 AM2 426.83 6 2 2.44 Low No 0.55 
3 AM13 471.28 6 2 2.75 Low No 0.55 
4 AM12 437.39 8 2 1.86 Low No 0.55 
5 AM17 446.43 8 2 2.35 Low No 0.55 
6 AM58 387.34 8 1 2.45 High No 0.55 
7 AM5 408.39 7 3 1.91 Low No 0.55 
8 AM14 429.43 8 2 1.84 Low No 0.55 
9 AM16 458.47 8 2 2.44 Low No 0.55 
10 AM19 428.44 7 2 2.27 Low No 0.55 
11 AM52 378.30 8 1 1.97 Low No 0.55 
12 AM57 387.34 8 1 2.4 High No 0.55 
13 Co-cryst 

Ligand (MRK) 
349.41 4 2 2 Low No 0.55 

14 Canagliflozin 444.52 6 4 3.27 High No 0.55 
15 Dapagliflozin 408.87 6 4 3.12 High No 0.55 
16 Dorzagliatin 462.93 6 3 3.08 High No 0.55 

MRK, Canagliflozin, Dapagliflozin, and 
Dorzagliatin fall within the range of 0.197-0.545 in 
this regard. Regarding ORAT (LD50) mol/kg, AM2 
displays a higher value of 2.692, implying 
relatively lower toxicity when compared to AM35 
(3.325) and MRK (0.969). All compounds show 
evidence of hepatotoxicity. In terms of skin 
sensitization, none of the compounds, including 
AM2, AM35, and MRK, exhibit signs of skin 
sensitization. For T.Pyriformis toxicity, AM2 
registers a log µg/mL value of 0.338, whereas 
AM35 (0.285) has a slightly lower value of 0.319. 
MRK displays an equivalent value to that of AM35, 
at 0.285. Regarding minnow toxicity, AM35 
demonstrates a lower toxicity level with a value of 
-0.233, while AM2 and MRK have values of -0.622 
and 1.657, respectively, as shown in table 4. In 
summary, when comparing AM35, AM2, and 
MRK, AM2 exhibits favorable characteristics in 
terms of AMES toxicity, MTD (human) log 
mg/kg/day, ORAT (LD50) mol/kg, hepatotoxicity, 
T.Pyriformis toxicity, and minnow toxicity. 
However, a more comprehensive assessment and 

analysis are necessary to thoroughly evaluate these 
compounds and determine their suitability for 
specific applications. 
Using a rational drug design approach, 60 
heterocyclic derivatives were designed with the aim 
of evaluating their potential as antidiabetic agents, 
specifically targeting glucokinase (GKA). These 
molecules were subjected to molecular docking 
simulations to assess their binding to the 
glucokinase binding site. MRK (a co-crystallized 
ligand), Dorzagliatin (approved by the Japan FDA 
as a GKA), Dapagliflozin, and Canagliflozin were 
utilized as standard references and sought 
compounds not yet available on the market. The 2D 
and 3D structures of these designed compounds 
were generated using Chemdraw 2D and 
Chemdraw 3D, respectively, and their steric 
hindrances were minimized using MM2. 
Subsequently, the ligand was extracted from the 
glucokinase receptor protein, which was obtained 
from the Protein Data Bank. Autodock software 
was employed to investigate the binding affinities 
of all the compounds. Lead compounds with 
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binding affinities surpassing that of the 
conventional MRK molecule were identified, with 
Compound AM35 exhibiting the highest binding 
affinity at -11.6 Kcal/mol for the active GK site. 
Following the determination of binding affinities, 
the interactions between the protein and the 
molecules were visualized using PyMOL software, 
and further insights into these interactions were 

obtained using Discovery Studio. Key amino acid 
residues involved in interactions at the GK site were 
TYR214T, ILE159, ALA456, VAL62, ILE211, and 
MET210. Subsequently, 11 promising hit 
compounds were selected based on their binding 
affinities and subjected to pharmacokinetic profile 
prediction using SwissADME. 

 
Table 4: Toxicity Profile of Potent compounds 

Sr.
no 

Compound AMES 
toxicity 

MTD (human) log 
mg/kg/day 

ORAT 
(LD50) 
mol/kg 

Hepatotox
icity 

Skin 
Sensitiza

tion 

T.Pyriformis 
toxicity log 

µg/mL 

Minnow 
toxicity 
(mM) 

1 AM35 Yes 0.798 3.325 Yes No 0.285 -0.233 
2 AM2 No 0.163 2.692 Yes No 0.338 -0.622 
3 Co-cryst Ligand 

(MRK) 
Yes 0.545 0.969 Yes No 0.285 1.657 

4 Canagliflozin No 0.229 2.755 No No 0.285 -0.499 
5 Dapagliflozin No 0.197 2.597 No No 0.289 1.567 
6 Dorzagliatin No 0.428 3.328 Yes No 0.308 2.394 

*MTD =  Max Tolerated Dose, ORAT = Oral Rat Acute Toxicity, LD50 = Lethal Dose 
 

Among these hits, SwissADME indicated that 
compounds AM35 and AM2 possessed favorable 
pharmacokinetic profiles, including an optimal 
LogP value. Notably, all compounds met Lipinski's 
rule of five criteria, featuring a molecular weight 
below 500, fewer than 10 H-bond acceptors, fewer 
than 5 H-bond donors, and a LogP value below 5. 
Furthermore, these compounds exhibited high 
gastrointestinal (GI) absorption, enhancing their 
potential for systemic absorption and therapeutic 
efficacy. This characteristic is pivotal for drug 
candidates. In conclusion, the analysis of 
SwissADME profiles, adherence to Lipinski's rule 
of five, high GI absorption, and no potential blood-
brain barrier (BBB) permeability collectively 
suggest that these compounds possess promising 
drug-like properties. Extensive investigations and 
evaluations are warranted to explore their 
therapeutic applications, particularly in the context 
of type 2 diabetes. Experimental studies using 
organism models like Streptozotocin induced 
diabetic rat model may also provide insights into 
their potential as lead molecules with potent 
glucokinase activity for treating type 2 diabetes.  
As well as contributing to the advancement of 
computational methodologies in drug development, 
these novel heterocyclic derivatives provide 
insights into their efficacy as Glucokinase 
activators. Providing improved Glucokinase 
activation compared to existing standards, the 

results of this study might provide a new class of 
compounds. This has profound implications for 
conditions related to glucose metabolism, 
potentially opening avenues for more effective 
therapeutic interventions.  
 

4. Conclusions 
In summary, our study encompassed a thorough 
rational design of 60 novel heterocyclic derivatives, 
with the primary objective of identifying potential 
lead compounds with potent glucokinase (GK) 
activation capabilities for treating type 2 diabetes. 
These compounds underwent docking studies 
against the GK binding site, and their 2D and 3D 
structures were scrutinized through Chemdraw 
software. MM2 was used to minimize steric 
hindrance in their structures and Autodock software 
to assess their binding affinities. Based on these 
binding affinities, Compound AM35 emerged as 
the most promising candidate, boasting the highest 
binding affinity of -11.6 Kcal/mol for the active GK 
site. Further analysis of the interaction between 
these compounds and the protein was conducted 
using Pymol and Discovery Studio, revealing 
significant interactions with amino acid residues 
TYR214T, ILE159, ALA456, VAL62, ILE211, and 
MET210 within the GK site. Then the selected 
compounds were subjected to pharmacokinetic 
profile prediction using SwissADME. Among these 
compounds, AM35 and AM2 exhibited favorable 
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pharmacokinetic profiles with optimal LogP values. 
Notably, all analyzed compounds had a molecular 
weight below 500, aligning with the criteria for 
assessing drug-like properties and adhering to 
Lipinski's rule of five. Additionally, our designed 
compounds demonstrated high gastrointestinal 
absorption, signifying their potential for efficient 
bloodstream absorption—an essential attribute for 
drug candidates. In summary, our findings 
underscore the promising drug-like properties of 
these compounds, with AM2 standing out as a 
potential lead molecule for further development. 
Comparing the compounds AM35, AM2, and MRK 
based on various toxicity and safety parameters 
provides valuable insights. AM2 presents a 
favorable profile with non-AMES toxicity, a 
positive MTD (human) log mg/kg/day value 
indicating potential safe dosage, a higher ORAT 
(LD50) mol/kg value indicating lower toxicity, 
non-hepatotoxicity, no skin sensitization, moderate 
T.Pyriformis toxicity, and lower minnow toxicity. 
In contrast, AM35 exhibits AMES toxicity, a 
negative MTD (human) log mg/kg/day value 
warranting caution in determining the maximum 
tolerated dose, a relatively lower ORAT (LD50) 
mol/kg value indicating higher toxicity, non-
hepatotoxicity, no skin sensitization, lower 
T.Pyriformis toxicity, and moderate minnow 
toxicity. MRK, being the standard compound, 
shows AMES toxicity, a negative MTD (human) 
log mg/kg/day value, a moderate ORAT (LD50) 
mol/kg value, hepatotoxicity, no skin sensitization, 
higher T.Pyriformis toxicity, and moderate minnow 
toxicity. Taking these findings into account, AM35 
presents a more promising toxicity and safety 
profile compared to AM2 and MRK. Nonetheless, 
it is vital to emphasize that comprehensive studies 
and evaluations are imperative to fully grasp the 
potential risks and benefits associated with these 
compounds and their suitability for specific 
applications. Future investigations should prioritize 
conducting experimental studies using organism 
models such as the Streptozotocin-induced diabetic 
rat model to assess the compounds' glucokinase 
activation potential and explore their therapeutic 
applications in treating type 2 diabetes. 
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